How to approach Network Engineer Life
Today i wanna write for how to approach network engineer life. Please collect every single piece of networking experience and put into your job and apply it for customer network environment.
Think Different with other people. Don't follow the other people thinking and way. Concentrate on what is your first step to your career. First time before i came to networking, I am started in System Engineer life. for networker Do you have free time ? please read on product manaul and product features. and learn market leader products. Network engineer have to know which product have what kind of features. For example, you are going to deploy one of voip network. What things we need to know. * What is their network design ? * only pure data or any integarated network ? * How many users are going to use for voip ? * What kind of usage (Daisy chain users or Separate) ? * How many POE switch ? * what is PoE ? and so on ...
Suggest for a good network engineer.
1.Please help to customer to troubleshoot their network problem.
2.Propose the best networking design to customer for long term.
3. Apply every single single knowledge that u have and apply it . help the customer and make people life easier :)
That's all i know. Everythings you do refelect on your own personality.
Give the best things, the best idea to others and return good things back to you :)
Friday, 28 October 2011
IBGP
Today i wanna introduce how is BGP work withing iBGP relationship. BGP is is like application to make routing over the other routing protocol like over any eigrp or ospf network. BGP need to be manually neighbor with other peers. Here is the pic to simulate for IBGP relationship between R1 and R2.
R1 Configuration
===========
!
interface Loopback0
ip address 1.1.1.1 255.0.0.0
!
interface Serial0/0
ip address 192.168.0.1 255.255.255.0
serial restart-delay 0
!
router bgp 100
no synchronization
bgp log-neighbor-changes
network 1.0.0.0
neighbor 192.168.0.2 remote-as 100
no auto-summary
!
R2 Configuration
=============
!
interface Loopback0
ip address 2.2.2.2 255.0.0.0
!
interface Serial0/0
ip address 192.168.0.2 255.255.255.0
serial restart-delay 0
!
!
router bgp 100
no synchronization
bgp log-neighbor-changes
network 1.0.0.0
neighbor 192.168.0.2 remote-as 100
no auto-summary
!
After configuration as above we can learn on how to relate between two Routers R1 and R2. Loopback 0 will advertise on BGP. Hope reader enjoy. :)
R1 Configuration
===========
!
interface Loopback0
ip address 1.1.1.1 255.0.0.0
!
interface Serial0/0
ip address 192.168.0.1 255.255.255.0
serial restart-delay 0
!
router bgp 100
no synchronization
bgp log-neighbor-changes
network 1.0.0.0
neighbor 192.168.0.2 remote-as 100
no auto-summary
!
R2 Configuration
=============
!
interface Loopback0
ip address 2.2.2.2 255.0.0.0
!
interface Serial0/0
ip address 192.168.0.2 255.255.255.0
serial restart-delay 0
!
!
router bgp 100
no synchronization
bgp log-neighbor-changes
network 1.0.0.0
neighbor 192.168.0.2 remote-as 100
no auto-summary
!
After configuration as above we can learn on how to relate between two Routers R1 and R2. Loopback 0 will advertise on BGP. Hope reader enjoy. :)
Thursday, 20 October 2011
Introduction to BGP
Just share that i learn from today.
ibgp batch updates sent once every 5 seconds
ebgp updates sent once every 30 seconds.
bgp uses port 179 and maintain neighbors or peer relationship
Hello messages sent once every 60 seconds with a holddown of 180 seconds. capable of md5 authentication.
######BGP Route Selection Criteria######
1. Exclude routes with inaccessible next hop
2. Prefer highest weight (Local to router)
3. Prefer highest local preference (global within AS)
4. Prefer routes that router originated
5. Prefer shortest AS Path(only length is compared)
6. Prefer Lowest Origin code (IGP < EGP < incomplete)
7.Prefer lowest MED
8. Prefer external (EBGP) paths over internal (IBGP)
9. For IBGP paths, prefer path through closet IGP neighbor
10. For EBGP paths, prefer oldest (most stable) path
11. Prefer paths from router with the lowest BGP router id
ibgp batch updates sent once every 5 seconds
ebgp updates sent once every 30 seconds.
bgp uses port 179 and maintain neighbors or peer relationship
Hello messages sent once every 60 seconds with a holddown of 180 seconds. capable of md5 authentication.
######BGP Route Selection Criteria######
1. Exclude routes with inaccessible next hop
2. Prefer highest weight (Local to router)
3. Prefer highest local preference (global within AS)
4. Prefer routes that router originated
5. Prefer shortest AS Path(only length is compared)
6. Prefer Lowest Origin code (IGP < EGP < incomplete)
7.Prefer lowest MED
8. Prefer external (EBGP) paths over internal (IBGP)
9. For IBGP paths, prefer path through closet IGP neighbor
10. For EBGP paths, prefer oldest (most stable) path
11. Prefer paths from router with the lowest BGP router id
Friday, 14 October 2011
Sunday, 9 October 2011
Introduction to OSPF
Today i will introduce my blog reader to explain how to calculate ospf cost and ospf fundamental.
OSPF is Open shortest path first routing protocol which is widely used in routing . It is no rule for proprietary of only vendor. All most all vendor like cisco, extreme, and juniper router can able to load and run OSPF routing protocol. Basically in ospf, there is one backbone area called area 0 which can connect all routers including other Area Border Router (ABR) or Autonomous System Border Router.(ASBR).
Today i just explain how to get from Router R1 to reach Router R3 loopback interface and how to get ospf cost from R1 -- > R3. Here is diagram.
R1 Configuration
============
!
interface Loopback0
ip address 1.1.1.1 255.0.0.0
ip ospf 1 area 0
!
interface Serial0/0
ip address 192.168.12.1 255.255.255.252
ip ospf 1 area 0
!
end
R2 Configuration
=============
interface Loopback0
ip address 2.2.2.2 255.0.0.0
ip ospf 1 area 0
!
interface Serial0/0
ip address 192.168.12.2 255.255.255.252
ip ospf 1 area 0
!
interface FastEthernet1/0
ip address 192.168.23.2 255.255.255.0
ip ospf 1 area 0
no shutdown
!
end
R3 Configuration
=============
!
interface Loopback0
ip address 3.3.3.3 255.0.0.0
ip ospf 1 area 0
!
interface FastEthernet0/0
ip address 192.168.23.3 255.255.255.0
ip ospf 1 area 0
!
end
====================================================
After finish configuring on each router. OSPF process will start and you can check by using
show ip ospf neighbor command on each router. Here is R2 is forming OSPF neighborship with
R3 (3.3.3.3) and R1 (192.168.12.1).
We can calculate OSPF costs on each interface by using below costs:
Here can see route 1.1.1.1 [110/66] means that
110 is OSPF administrative distance.
66 means ospf costs from R3 to R1.
I will show how to calculate to get 66 number. Based on OSPF costs above mentions,
we can calculate here:
All Total Cost = R1 Serial Interface to R2 + R2 ethernet link to R3 + R3 Loopback interface cost
= 64 + 1 + 1
= 66
Hope reader can enjoy routing :)
OSPF is Open shortest path first routing protocol which is widely used in routing . It is no rule for proprietary of only vendor. All most all vendor like cisco, extreme, and juniper router can able to load and run OSPF routing protocol. Basically in ospf, there is one backbone area called area 0 which can connect all routers including other Area Border Router (ABR) or Autonomous System Border Router.(ASBR).
Today i just explain how to get from Router R1 to reach Router R3 loopback interface and how to get ospf cost from R1 -- > R3. Here is diagram.
Let me help to configure same as below command on each router interface.
R1 Configuration
============
!
interface Loopback0
ip address 1.1.1.1 255.0.0.0
ip ospf 1 area 0
!
interface Serial0/0
ip address 192.168.12.1 255.255.255.252
ip ospf 1 area 0
!
end
R2 Configuration
=============
interface Loopback0
ip address 2.2.2.2 255.0.0.0
ip ospf 1 area 0
!
interface Serial0/0
ip address 192.168.12.2 255.255.255.252
ip ospf 1 area 0
!
interface FastEthernet1/0
ip address 192.168.23.2 255.255.255.0
ip ospf 1 area 0
no shutdown
!
end
R3 Configuration
=============
!
interface Loopback0
ip address 3.3.3.3 255.0.0.0
ip ospf 1 area 0
!
interface FastEthernet0/0
ip address 192.168.23.3 255.255.255.0
ip ospf 1 area 0
!
end
====================================================
After finish configuring on each router. OSPF process will start and you can check by using
show ip ospf neighbor command on each router. Here is R2 is forming OSPF neighborship with
R3 (3.3.3.3) and R1 (192.168.12.1).
We can calculate OSPF costs on each interface by using below costs:
- Fastethernet : 1
- Serail : 64
- Loopback : 1
Here can see route 1.1.1.1 [110/66] means that
110 is OSPF administrative distance.
66 means ospf costs from R3 to R1.
I will show how to calculate to get 66 number. Based on OSPF costs above mentions,
we can calculate here:
All Total Cost = R1 Serial Interface to R2 + R2 ethernet link to R3 + R3 Loopback interface cost
= 64 + 1 + 1
= 66
Hope reader can enjoy routing :)
Thursday, 6 October 2011
Trunking Between Cisco and Extreme
Above figures for connection between Two different product Cisco and Extreme. We just consider Cisco as Core Layer and Exreme as Access Layer switch to work in VoIP World.
There are 2 switches implemented called cisco catalyst 3560 and extreme x250e-48p.
One dhcp server on Fa0/1 port of Cisco switch will distribute vlan called Data vlan 10,20 and Voice vlan 110,120 via trunk link.
Management vlan 100 also configured on both switch for using telnet remote management.
Vlan Name | Vlan IP Assignment |
Vlan 10 | 10.10.1.1/24 |
Vlan 20 | 10.10.2.1/24 |
Vlan 110 | 192.168.10.1/24 |
Vlan 120 | 192.168.20.1/24 |
Vlan 130(Server) | 172.16.172.27/24 |
Cisco Switch Configuration
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
switchport access vlan 130
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/4
switchport access vlan 130
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/5
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
switchport trunk encapsulation dot1q
switchport trunk native vlan 100
switchport trunk allowed vlan 10,20,100,110,120
switchport mode trunk
no cdp enable
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan10
ip address 10.10.1.1 255.255.255.0
ip helper-address 172.16.172.20
!
interface Vlan20
ip address 10.10.2.1 255.255.255.0
ip helper-address 172.16.172.20
!
interface Vlan100
ip address 192.168.100.1 255.255.255.0
!
interface Vlan110
ip address 192.168.10.1 255.255.255.0
ip helper-address 172.16.172.20
!
interface Vlan120
ip address 192.168.20.1 255.255.255.0
ip helper-address 172.16.172.20
!
interface Vlan130
ip address 172.16.172.27 255.255.255.0
!
Extreme Switch Configuration
create vlan "control"
configure vlan control tag 100
create vlan "Vlan10"
configure vlan Vlan10 tag 10
create vlan "Vlan20"
configure vlan Vlan20 tag 20
create vlan "voice-vlan10"
configure vlan voice-vlan10 tag 110
create vlan "voice-vlan20"
configure vlan voice-vlan20 tag 120
configure vlan control add ports 47 untagged
configure vlan Vlan10 add ports 47 tagged
configure vlan Vlan10 add ports 1-20 untagged
configure vlan Vlan20 add ports 47 tagged
configure vlan Vlan20 add ports 21-40 untagged
configure vlan voice-vlan10 add ports 1-20, 47 tagged
configure vlan voice-vlan20 add ports 21-40, 47 tagged
configure vlan control ipaddress 192.168.100.2 255.255.255.0
configure iproute add default 192.168.100.1
configure bootprelay add 172.16.172.20 vr VR-Default
enable bootprelay vlan control
enable bootprelay vlan Vlan10
enable bootprelay vlan Vlan20
enable bootprelay vlan voice-vlan10
enable bootprelay vlan voice-vlan20
enable dhcp ports 1-20 vlan Vlan10
enable dhcp ports 21-40 vlan Vlan20
enable dhcp ports 1-20 vlan voice-vlan10
enable dhcp ports 21-40 vlan voice-vlan20
configure stpd "s0" mode dot1w
enable stpd "s0"
configure stpd "s0" add vlan "Vlan10" ports all
configure stpd "s0" add vlan "Vlan20" ports all
configure stpd "s0" add vlan "voice-vlan10" ports all
configure stpd "s0" add vlan " voice-vlan20" ports all
Hope reader enjoy it :)
Network design for switching
Since i come into networking field. I just learn the how to suggest proposed design to customer and how to give real solutions to customers in order to fix with customer budget, project quality and some kind of redundancy. This section i wanna introduce for switching design. Based on below diagrams.
Normally network engineer create vlan group based on customer department and some based on location and some based on customer proposed subnet information. From my diagram i just create vlan based on department like Manufacturing , Marketing , Sales ...etc. I design switching into 3 tier network. Accounting , Engineering, Sale and Human resources department are connecting to 1st tier switch. Manufacturing , Marketing, Executive and IT department are connecting to 2nd tier switch. All these 1st and 2nd tier switches connect back to 3rd tier CORE switch.
Here comes with Connection link for my design as well. 1st Tier switch to 2nd tier switch will be trunk link if they belong to more than one vlan.
The final picture is considered the case for network redundancy. In this design , one of Core Switch have problems or down, the other core switch can handle to get network connections.
Okay. That's for some network drawing. Hope reader on my blog is happy to see and get idea on it. :)
Normally network engineer create vlan group based on customer department and some based on location and some based on customer proposed subnet information. From my diagram i just create vlan based on department like Manufacturing , Marketing , Sales ...etc. I design switching into 3 tier network. Accounting , Engineering, Sale and Human resources department are connecting to 1st tier switch. Manufacturing , Marketing, Executive and IT department are connecting to 2nd tier switch. All these 1st and 2nd tier switches connect back to 3rd tier CORE switch.
Here comes with Connection link for my design as well. 1st Tier switch to 2nd tier switch will be trunk link if they belong to more than one vlan.
The final picture is considered the case for network redundancy. In this design , one of Core Switch have problems or down, the other core switch can handle to get network connections.
Okay. That's for some network drawing. Hope reader on my blog is happy to see and get idea on it. :)
Starting Journey to Cisco
Today morning i went to my customer site for a project activity. I heard the news from customer that
" Steve Job is not alive" . It is Great loss. I love the words from " Stay Hungry, Stay Foolish" .
Everytime i went to customer site and liase with customer to get network information. They asked me same double questions in many times " Why u r working in networking ? I never seen before lady in network engineering" . I reply the same questions again to customer " I love my job, I love networking, I love switching & routing. "
Today i just introduce my journey to Cisco Switching and routing learning. I will share with my knowledge on other products like Extreme , Nortel , Hp.
Please keep on looking and give me a comment. Now currently i m working as a network engineer in singapore VoIP company, especially providing data part ( Cisco, Extreme, HP, Nortel, 3com) ... :)
" Steve Job is not alive" . It is Great loss. I love the words from " Stay Hungry, Stay Foolish" .
Everytime i went to customer site and liase with customer to get network information. They asked me same double questions in many times " Why u r working in networking ? I never seen before lady in network engineering" . I reply the same questions again to customer " I love my job, I love networking, I love switching & routing. "
Today i just introduce my journey to Cisco Switching and routing learning. I will share with my knowledge on other products like Extreme , Nortel , Hp.
Please keep on looking and give me a comment. Now currently i m working as a network engineer in singapore VoIP company, especially providing data part ( Cisco, Extreme, HP, Nortel, 3com) ... :)
Subscribe to:
Posts (Atom)