Friday 28 October 2011

IBGP

Today i wanna introduce how is BGP work withing iBGP relationship. BGP is  is like application to make routing over the other routing protocol like over any eigrp or ospf network. BGP need to be manually neighbor with other peers. Here is the pic to simulate for IBGP relationship between R1 and R2.






R1 Configuration
===========
!
interface Loopback0
 ip address 1.1.1.1 255.0.0.0
!
interface Serial0/0
 ip address 192.168.0.1 255.255.255.0
 serial restart-delay 0
!

router bgp 100
 no synchronization
 bgp log-neighbor-changes
 network 1.0.0.0
 neighbor 192.168.0.2 remote-as 100
 no auto-summary
!

R2 Configuration
=============
!
interface Loopback0
 ip address 2.2.2.2 255.0.0.0
!
interface Serial0/0
 ip address 192.168.0.2 255.255.255.0
 serial restart-delay 0
!
!
router bgp 100
 no synchronization
 bgp log-neighbor-changes
 network 1.0.0.0
 neighbor 192.168.0.2 remote-as 100
 no auto-summary
!

After configuration as above we can learn on how to relate between two Routers R1 and R2. Loopback 0 will advertise on BGP. Hope reader enjoy. :)

1 comment:

  1. In R2: the configuration should be
    !
    router bgp 100
    no synchronization
    bgp log-neighbor-changes
    network 1.0.0.0
    neighbor 192.168.0.1 remote-as 100
    no auto-summary
    !

    ReplyDelete